Перейти к основному содержанию

HP Smart Array — cache module status failed

HP Proliant DL360 Gen9

Сегодня занимаемся диагностикой сервера HPE Proliant DL360 Gen9. Ошибка с RAID контроллером.

HP Smart Array — cache module status failed

Проблему выявила система мониторинга. Выглядит не слишком страшно. Сервер продолжает работать, виртуальные машины на сервере крутятся, но мониторинг ругается.

hpe

Смотрим в iLO.В списке устройств и батарейка и контроллер зелёные. Но в углу светится иконка предупреждения.

hpe

А вот при просмотре RAID контроллера видим, что Сache module status в состоянии failed. Что-то похожее уже встречалось:

HP Smart Array — cache module status degraded

Отказал кэш RAID контроллера Smart Array P440ar.

Освобождаем сервер, загружаем в SSA и смотрим подробности.

hpe

Статус:

The cache for Smart Array P440ar in Embedded Slot has been disabled because the backup operation failed.

Кэш контроллера отключён.

Теперь нужно поразмыслить, проблема может быть в нескольких местах, самые очевидные:

  • Батарейка
  • RAID контроллер
  • Кэш RAID контроллера
  • Материнская плата

На данном контроллере кэш распаян на плате, так что проблема в RAID контроллере или кэше RAID контроллера для нас не отличимы, в обоих случаях решением проблемы будет замена контроллера. Проще всего методом исключений нужно проверить батарейку. Заменим на аналогичную с рабочего сервера или ЗИП.

Замена батарейки не помогла. Ошибка не устранена.

hpe

Попробуем включить кэш. Re-enable Cache Module.

hpe

Yes.

hpe

Ошибка:

The operation failed. An unknown error occured during execution.

hpe

Статус кэша:

Cache disabled; backup to flash memory failed

Смотрим в лог Integrated Management Log.

hpe

При загрузке сервера происходит ошибка:

Option ROM POST Error: 1797-Slot 0 Drive Array - Write Back Cache Previously Failed. Caching is disabled. Action: Replace the Cache Module

Предположение следующее. Сервер загружается, считывает конфигурацию массивов с дисков и пытается записать её в кэш, распаянный на плате контроллера. Записать не может, кэш отключается, отображается ошибка.

Контроллер, конечно, можно использовать, но только в режиме HBA адаптера. Нам не подходит. Будем менять RAID контроллер.

После замены контроллера его нужно прошить, чтобы не было проблем с массивами. Проблема ушла.

Теги

 

Похожие материалы

HPE ProLiant DL360 Gen9 — замена материнской платы

У сервера HPE Proliant DL360 Gen9 сгорела мать. Меняем, ничего сложного. Вытаскиваем сервер и размещаем на столе, так с ним удобнее работать. Если нет возможности вынуть сервер, то метеринскую плату можно заменить в стойке.

Теги

HPE H241 Smart HBA выходит из строя

На сервере HPE Proliant DL20 начал глючить адаптер HPE H241 Smart HBA. Я собирался написать длинную статью про то, как с термопастой, отвёртками, щётками и спиртом наперевес борюсь с окислением контактов и героически побеждаю проблему — не вышло.