Перейти к основному содержанию

Поддержка неподдерживаемых трансиверов в Linux

Linux

Имеем

  • Сервер Supermicro с материнкой MBD-X10DRi
  • Операционная система Oracle Linux 7.5
  • Сетевая карта Intel X520-DA2 10 Гигабит SFP+
  • Трансиверы Gigalink GL-OT-ST05LC2-0850-0850-M

Проблема

При загрузке ошибка:

ixgbe failed to load because an unsupported SFP+ module type was detected

Сетевой интерфейс не поднимается.

Решение проблемы

Использовать опцию allow_unsupported_sfp=1 в драйвере ixgbe.

Как это сделать

В /etc/default/grub дописать опцию:

GRUB_CMDLINE_LINUX=" ixgbe.allow_unsupported_sfp=1"

Обновить grub.cfg:

grub2-mkconfig -o /boot/grub2/grub.cfg

Перезагрузить сервер. 

intel 10g

gigalink sfp+

 

Похожие материалы

Установка FC адаптера в сервер Supermicro SYS-2029U-TN24R4T

Здравствуй, юный сисадмин. Сегодня мы с тобой будем устанавливать два Fibre Channel адаптера в сервер Supermicro SYS-2029U-TN24R4T. Вернее, ставить буду я. А ты будешь, попивая пивко, на это смотреть.

Установка и настройка keepalived на примере MultiFactor Ldap Adapter

Есть два сервера с операционной системой Ubuntu 20.04.4 LTS. Но обоих серверах развёрнут LDAP proxy сервер на базе Multifactor. По сути это обычные LDAPS сервера, которые неплохо было бы объединить в один отказоустойчивый кластер Master— Slave с плавающим виртуальным IP-адресом. Сделаем это с помощью keepalived.