Перейти к основному содержанию
 

Установка PostgreSQL 12 для 1C

1C

Сохраню инструкцию по установке БД PostgreSQL для 1С. Естественно, использую пакеты с сайта 1С:

  • libpq5_12.7-1.1C_amd64.deb
  • postgresql-12_12.7-1.1C_amd64.deb
  • postgresql-client-12_12.7-1.1C_amd64.deb

sql

В качестве операционной системы используется Ubuntu 18.04.5 LTS.

Обновляем ОС:

apt-get update
apt-get upgrade

Проверяем локаль, она должна быть установлена в ru_RU.UTF-8:

locale

Если это не так, то выполняем:

dpkg-reconfigure locales

sql

Выбираем установленные локали, я выбираю две:

  • ru_RU.UTF-8
  • en_US.UTF-8

sql

Ok.

sql

Локаль по умолчанию в системном окружении выбираем ru_RU.UTF-8. Ok.

sql

Устанавливаем вспомогательные пакеты:

apt-get install postgresql-client-common postgresql-common libxslt1.1 ssl-cert libllvm6.0

Устанавливаем пакеты от 1С:

dpkg -i libpq5_12.7-1.1C_amd64.deb
dpkg -i postgresql-client-12_12.7-1.1C_amd64.deb
dpkg -i postgresql-12_12.7-1.1C_amd64.deb

Дополнительно

У меня все пакеты установились без проблем, но случается всякое.

При возникновении ошибки:

Пакет libssl1.0.0 не установлен.

Лечим:

wget http://archive.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.6_amd64.deb
dpkg -i  libssl1.0.0_1.0.2n-1ubuntu5.6_amd64.deb

При возникновении ошибки:

Пакет libicu55 не установлен.

Лечим:

wget http://security.ubuntu.com/ubuntu/pool/main/i/icu/libicu55_55.1-7ubuntu0.5_amd64.deb
dpkg -i ./libicu55_55.1-7ubuntu0.5_amd64.deb

Теги